17
Сен
2016

Ошибка сборки: Error:Error converting bytecode to dex: Cause: com.android.dex.DexException: Multiple dex files define

Добрый день! Уже несколько дней пытаюсь собрать проект, но ничего не выходит, опыта у меня маловато, поэтому ответ так и не нашел. См проект собран без ошибок, но когда начинаю проверять его на эмуляторе, телефоне (пробовал все способы), то выдает вот такие ошибки:

Error:Error converting bytecode to dex: Cause: com.android.dex.DexException: Multiple dex files define Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat$AccessibilityServiceInfoVersionImpl;

:app:transformClassesWithDexForDebug FAILED

Error:Execution failed for task ':app:transformClassesWithDexForDebug'. com.android.build.api.transform.TransformException: com.android.ide.common.process.ProcessException: java.util.concurrent.ExecutionException: com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command 'C:\Program Files\Java\jdk1.8.0_45\bin\java.exe'' finished with non-zero exit value 2

Вот мой gradle:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 17
    buildToolsVersion "23.0.2"

    defaultConfig {
        applicationId "com.Raduga.radio"
        minSdkVersion 11
        targetSdkVersion 24
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
        }
    }
}

dependencies {

    compile files('libs/aacdecoder-android-0.6.1.jar')
    compile files('libs/GoogleAdMobAdsSdk-6.2.1.jar')

    compile project(':cheetah-mobile-3.4.7')
    compile project(':unity-ads-1.5.8')
    compile files('libs/android-support-v4-23.1.1.jar')
    compile files('libs/appodeal-1.15.3.jar')
    compile files('libs/applovin-6.3.0.jar')
    compile files('libs/chartboost-6.5.1.jar')
    compile files('libs/flurry-analytics-6.5.0.jar')
    compile files('libs/my-target-4.5.10.jar')
    compile files('libs/yandex-metrica-2.41.jar')
    compile files('libs/aacdecoder-android-0.6.1.jar')
    compile files('libs/android-support-v7-recyclerview-23.1.1.jar')

    compile 'com.google.android.gms:play-services-ads:9.4.0'
    compile 'com.google.android.gms:play-services-location:9.4.0'
    compile 'com.google.android.gms:play-services-maps:9.4.0'

 }

targetSdkVersion 24 мeнял на 23 - 17 - 10 была изначально , это купленный шаблон.

Очень прошу помощи! Спасибо!

Источник: https://ru.stackoverflow.com/questions/567191/%D0%9E%D1%88%D0%B8%D0%B1%D0%BA%D0%B0-%D1%81%D0%B1%D0%BE%D1%80%D0%BA%D0%B8-errorerror-converting-bytecode-to-dex-cause-com-android-dex-de

Тебе может это понравится...

Добавить комментарий