21
Дек
2017

Не могу установить расширение cryptopro для php

Ставлю расширение под Ubuntu server 14x64

Есть инструкция на сайте:

http://cpdn.cryptopro.ru/default.asp?url=content/cades/plugin-installation.html

Для сборки расширения libphpcades требуется:

Установить пакеты libboost-dev и php-dev из репозитория пакетов (сделал)

Установить КриптоПро CSP версии 4.0 или выше (сделал)

Установить пакет cprocsp-pki-2.0.0-cades.rpm и cprocsp-devel из состава КриптоПро ЭЦП SDK !!!
Вот тут затык, там только есть пакет devel а вот cades в архиве нет... что делать?
Поэтому дальше по инструкции не могу двигаться, не появились файлы для компиляции расширения.

Может кто-то ставил это расширение? Нужно для проверки цифровых подписей.

Источник: https://ru.stackoverflow.com/questions/761395/%D0%9D%D0%B5-%D0%BC%D0%BE%D0%B3%D1%83-%D1%83%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%B8%D1%82%D1%8C-%D1%80%D0%B0%D1%81%D1%88%D0%B8%D1%80%D0%B5%D0%BD%D0%B8%D0%B5-cryptopro-%D0%B4%D0%BB%D1%8F-php

Тебе может это понравится...

Добавить комментарий