19
Окт
2021

Не устанавливается библиотека через composer

Пытаюсь установить библиотеку https://github.com/amocrm/amocrm-api-php

В консоли хостинга в папке где лежит composer ввожу composer require amocrm/amocrm-api-library

Выдает ошибку

[InvalidArgumentException]
Package amocrm/amocrm-api-library has a PHP requirement incompatible with your PHP version, PHP extensions and Composer version

введите сюда описание изображения

Из этого я понимаю что ругается на версию PHP. Сама среда у меня версия 7.3

Composer пытался обновить командой composer update - не помогло

Что еще проверять? Добавляю что еще сделал: Обновил Composerкомандой composer self-update теперь другая ошибка выдается

 [InvalidArgumentException]                                                                                                        

Package amocrm/amocrm-api-library has a PHP requirement incompatible with your PHP version, PHP extensions and Composer version:
- amocrm/amocrm-api-library 0.6.1 requires php >=7.1 which does not match your installed version 5.6.40.

из этого опять же понимаю что ругается на версию среды якобы она 5.6.40 но захожу на хостинг и проверяю версия 7.3 введите сюда описание изображения Может где то в другом месте нужно проверять версию PHP?...

Источник: https://ru.stackoverflow.com/questions/1339857/%D0%9D%D0%B5-%D1%83%D1%81%D1%82%D0%B0%D0%BD%D0%B0%D0%B2%D0%BB%D0%B8%D0%B2%D0%B0%D0%B5%D1%82%D1%81%D1%8F-%D0%B1%D0%B8%D0%B1%D0%BB%D0%B8%D0%BE%D1%82%D0%B5%D0%BA%D0%B0-%D1%87%D0%B5%D1%80%D0%B5%D0%B7-composer

Тебе может это понравится...

Добавить комментарий