Tagged: composer

18
Май
2021

Пишу веб-приложение на Slim Framework. Пытаюсь пользоваться автозагрузкой классов через composer, но класс не подгружается, не знаю уже что делать

Мне нужно в файл index.php загрузить класс Reg, который находится в файле register_class.php, который в свою очередь лежит в директории src
Вот этот файл:

Вот файл composer.json:

А вот неполный файл index.php:

Когда я инициализирую объе…

28
Апр
2021

composer install: Cannot allocate memory

Клонирую проект, запускаю команду(внутри контейнера) composer install и получаю ошибку
mmap() failed: [12] Cannot allocate memory
Segmentation fault

Пробовал увеличить memory_limit, он не помогло. Удаляю один пакет из composer.json и Com…

08
Апр
2021

Не создается объект класса контроллера?

Я создаю каркас MVC приложения, используя composer и библиотеку AltoRouter Про .htaccess не забыл, все запросы направляю на Index.php, однако когда я хочу обработать маршрут, то у меня не создается экземпляр класса IndexController.
Ошибка:…

24
Фев
2021

Перестал работать composer и artisan в проекте Laravel 8 после миграции

Перестал работать composer и php artisan после миграции с базой данных.
Сделал миграцию после чего сайт повис. Я попробовал перезапустить сервер php artisan serve и в ответ не получил абсолютно ничего. думал проблема в composer но там тоже…

14
Фев
2021

Настройка VDS, ISP manager, Composer

Подскажите, пожалуйста, имея ISPmanager можно ли через composer настроить VDS или как? Нужно ли обновлять PHP до 7+ и т.д.? Или просто можно установить composer и запустить по ssh протоколу? Обьясните, пожалуйста

18
Янв
2021

как создать проект в laravel определённой версии (напрмер 7) через команду new

изучаю laravel скачал установщик (installer) и хочу создать проект с помощью команды laravel new name-project однако инсталлер ругается просит php 7.3 так как создаёт по умолчанию проект на 8й версии а у меня php версии 7.2 на опенсервере….

15
Янв
2021

Как установить php-ml?

Установил через composer. Вроде всё ок. Установилось в директории, где лежит php.exe
Однако, во всех примерах кода (у них в документации) требуется vendor/autoload.php
<?php
require_once __DIR__ . ‘/vendor/autoload.php’;

use Phpml\Clas…

10
Янв
2021

Как запустить проект созданный на yii2?

Попросили знакомые изменить немного им стили на сайте. И дали ссылку на репозиторий на битбакете.
Там проект на yii2 и честно говоря, я не совсем понимаю, как мне его у себя локально запустить. При запуске index.php ничего не происходит. К…

25
Дек
2020

Установка Yii2-advanced

Следуюя инструкции с сайта http://web-sprints.ru/ustanovka-yii2-na-openserver/
Пробовал установить, не работает первая команда на установку плагина, почитав еще, пробую команду
composer global update fxp/composer-asset-plugin —no-plugins
C…

17
Дек
2020

Как решить проблему совместимости пакетов в PHP?

Суть проблемы проста. Допустим у нас есть какая CMS’ка, которая построена на пакетах (Prestashop, Magento, OctoberCMS и т.д.). Мы написали некоторый модуль, и используем Guzzle версии 7. К нам приходить заказчик с магазином на Prestashop (…

04
Дек
2020

Не приходят данные из HTML-формы на Email

Ошибок нет ни в консоли ChromeDevTools, ни в логах… Т.е. форма ajax-ом отсылается (POST 200), но не приходит на Email.
Установил Composer на хостинге и PHPMailer через composer. Вот расположение файлов и папок, относящихся к проблеме:
/…

29
Окт
2020

Не удается подключить библиотеку PHPWORD для работы с doc/docx документами. Что я неправильно делаю?

Установил через консоль OpenServer библиотеку PHPWord по инструкции разработчика https://github.com/PHPOffice/PHPWord#installation
Composer ошибку не показал:

Но библиотека явно установилась некорректно, потому что при запуске скрипта под…

20
Окт
2020

Не запустился jii в XAMPP

Все пути верные, делаю пошагам. Но на одном из шагов никак не происходит запуск приложения. Что может быть? По фронту и бэкенду все аналогично, отображается не только папка web.

<VirtualHost *:80>
ServerName vabessonova.test

20
Сен
2020

composer ошибка при установке

устанавливаю библиотеку composer install в ответ ошибка, такая же ошибка если делаю composer update, что не так делаю? mcrypt поставил
Your requirements could not be resolved to an installable set of packages.

Problem 1
– scrivo/highl…

19
Сен
2020

composer нет vendor/autoload

Скачал библиотеку, github telegram-bot-sdk
она работает по compose, т.к. руки из одного места просто взял чей-то код,
include(‘vendor/autoload.php’); //Подключаем библиотеку
use Telegram\Bot\Api;

как блин подключить эту библиотеку, если …

06
Сен
2020

Установка FFMpeg на OpenServer

Всем привет!
Никак не могу понять как установить вот этот модуль https://github.com/PHP-FFMpeg/PHP-FFMpeg для OpenServer. В гугле не нашёл инструкций. На странице модуля написано, что его нужно устанавливать через https://getcomposer.org/….